Slow Performance in YouSendIt Express

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Slow Performance in YouSendIt Express

 

Symptoms

When you send a file by using YouSendIt Express for Windows, you may experience slow performance over a high-brandwidth and high-latency network. However, you do not see any performance issues if you view a webpage by using a web browser.

 

Cause

This issue can occur because of many factors, including native limitations with TCP/IP. 

 

Workaround

 

YouSendIt is committed to improving our customers' product experiences and will be including enhancements to Express in a future version.

 

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. We recommend that you use this process only if you really require this process. YouSendIt cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about how to back up and restore the registry, click the following article number:

 

322756  How to back up and restore the registry in Microsoft Windows

 

As a workaround, perform these steps to increase performance.

 

  1. Download the following .zip file to your computer. This file contains a Registration Entries (.reg) file to import registry subkeys and values.

    https://www.yousendit.com/download/UnlES3dsSWhveE5jR0E9PQ
  2. Open the .zip file and extract the afdwindow.reg file.
  3. Double-click on the afdwindow.reg file. Running this file will merge the contents into the local registry.
  4. Click Yes and then click OK.
  5. Restart your computer.

 

Detail:

The .reg file adds the following keys to the registry:

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFD\Parameters]

"DefaultReceiveWindow"=dword:00010000

"DefaultSendWindow"=dword:00010000

 

Started ‎01-17-2012 by
Modified ‎04-18-2012 by
Comments
by apee on ‎03-30-2012 02:47 AM

Wow, my upload problem is resolved with this workaround! But just make shure that the download performance doesn't suffer from the DefaultReceiveWindow parameter in the workaround. In my case the workaround limited the download speed to the upload speed which isn't the idea. Deleting the value (experimenting with higher values like multiplying by ten could help as well) restored the download performance before the workaround.

by fthaust on ‎04-30-2012 07:49 PM

Worked for me, thanks.

Gone from 70kpbs to 700kpbs.

 

Ben

by mailnorth on ‎12-03-2012 07:57 AM

Ya, just to keep tabs.... trying to upload a 180mb file is taking 30+ min (well thats what the ounter says right now, it did say 1 min when it started).

 

i tried setting the limit higher but to no success. i have business class internet and m rated speeds ar 50Mb down and 10Mb up.  if i start an upload via YSI-express then go reboot, upon restart the ysi upload resumes and it says its FLYING at 12Mbps... screaming fast i'd say but within a couple minutes it drops to dial-up upload speeds.

 

i'm also running this on a bare-bones new system that only has xp installed and YSI-express. so, it can't be AV slowing it down.  any ideas out there?

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